HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

Share | 
 

 OpenGL linker error on Mac OSX 10.6

View previous topic View next topic Go down 
AuthorMessage
Trunks7j
Guest



PostSubject: OpenGL linker error on Mac OSX 10.6   Fri Mar 12, 2010 3:10 am

Hey guys, love the demos I see of this engine, and I would really like to integrate it into some of my current SFML projects.

I managed to compile the libraries on OSX 10.6 using Luinecho's guide : Thanks by the way.

I'm writing a small test app however when I try to compile I seem to get a linker error that is related to openGL. Here's the output:

Code:
Undefined symbols:
  "_glEnable", referenced from:
      SPK::SFML::SFMLRenderer::render(SPK::Group const&)in libSPARK_SFML.a(SPK_SFML_All.o)
      SPK::SFML::SFMLRenderer::render(SPK::Group const&)in libSPARK_SFML.a(SPK_SFML_All.o)
      SPK::SFML::SFMLPointRenderer::innerRender(SPK::Group const&)in libSPARK_SFML.a(SPK_SFML_All.o)
      SPK::SFML::SFMLPointRenderer::innerRender(SPK::Group const&)in libSPARK_SFML.a(SPK_SFML_All.o)
      SPK::GL::GLQuadRenderer::render(SPK::Group const&)in libSPARK_GL.a(SPK_GL_All.o)
      SPK::GL::GLQuadRenderer::render(SPK::Group const&)in libSPARK_GL.a(SPK_GL_All.o)
      SPK::GL::GLQuadRenderer::render(SPK::Group const&)in libSPARK_GL.a(SPK_GL_All.o)
      SPK::GL::GLQuadRenderer::render(SPK::Group const&)in libSPARK_GL.a(SPK_GL_All.o)
      SPK::GL::GLQuadRenderer::render(SPK::Group const&)in libSPARK_GL.a(SPK_GL_All.o)

And several more symbols, but all seem to be related to OpenGL. I've imported libSPARK.a, libSPARK_GL.a, and libSPARK_SFML.a all into the frameworks of my xcode project, so I'm not sure whats going on here. Any ideas?
Back to top Go down
Luinechor



Messages : 3
Date d'inscription : 2010-02-22

PostSubject: Re: OpenGL linker error on Mac OSX 10.6   Fri Mar 12, 2010 9:29 am

Hey,

try adding 'OpenGL.framework' to your xcode project.
Back to top Go down
View user profile
Trunks7j
Guest



PostSubject: Re: OpenGL linker error on Mac OSX 10.6   Fri Mar 12, 2010 2:26 pm

That did it. Much appreciated.

I'm pretty new to developing for Mac. I like the new XCode that has the list of frameworks though, makes it very easy.
Back to top Go down
Sponsored content




PostSubject: Re: OpenGL linker error on Mac OSX 10.6   Today at 9:30 am

Back to top Go down
 
OpenGL linker error on Mac OSX 10.6
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Selenium RC; Permission denied on session.([error] Element not found ")
» Can I check the error message displayed or not in Selenium?
» Getting error when i run selenium script in Eclipse, please help
» Response_Code = -1 Error_Message = Request Error
» iexpoloreproxy https certificate error

Permissions in this forum:You cannot reply to topics in this forum
 :: English Forum :: Questions (en)-
Jump to: