HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

Share | 
 

 Problème setTexturingMode

View previous topic View next topic Go down 
AuthorMessage
Julien



Messages : 4
Date d'inscription : 2010-06-24

PostSubject: Problème setTexturingMode   Thu Jun 24, 2010 3:50 am

Bonjour,

Je viens de découvrir SPARK et je fais quelques tests dessus.
J'ai essayé de compiler la démo de feu. J'ai eu beaucoup de mal mais bon j'y suis arrivé.
L'application s'exécute mais j'ai une erreur d'exécution au niveau de fireRenderer->setTexturingMode(TEXTURE_2D); avec un message qui me dit que l'exception est non gérée avec une violation d'accès de la lecture de l'emplacement. Comment je pourrais résoudre cette erreur?

Merci d'avance
Back to top Go down
View user profile
stardeath
Committer


Messages : 140
Date d'inscription : 2009-08-24

PostSubject: Re: Problème setTexturingMode   Thu Jun 24, 2010 4:55 am

bonjour, quelle version de spark? as tu récupéré sur le svn?

ensuite quel renderer? opengl, directx, ou autre?

quelle plateforme, linux, windows?

quel compilateur, gcc, visual studio, si visual studio, que t'indique le débugger?

si il y a violation d'accès, il doit y avoir un pointeur null, mais où ...
Back to top Go down
View user profile
Julien



Messages : 4
Date d'inscription : 2010-06-24

PostSubject: Re: Problème setTexturingMode   Thu Jun 24, 2010 5:15 am

la version que j'ai est la dernière dispo en téléchargement, soit la 1.05.01. J'utilise opengl comme renderer et visual studio. En fait j'essaye juste de relancer le projet de démo du feu. Donc je ne comprend pas pourquoi j'ai un pointeur null. Surtout qu'il me met cette erreur que pour cette méthode de cette classe alors que les autres méthodes de la classe fonctionne parfaitement bien.
Back to top Go down
View user profile
stardeath
Committer


Messages : 140
Date d'inscription : 2009-08-24

PostSubject: Re: Problème setTexturingMode   Thu Jun 24, 2010 5:50 am

je suis au boulot là, je peux donc pas vérifier, mais le debugger il te dit quoi?
Back to top Go down
View user profile
Julien



Messages : 4
Date d'inscription : 2010-06-24

PostSubject: Re: Problème setTexturingMode   Thu Jun 24, 2010 9:13 am

j'ai résolu le problème. J'ai repris la solution d'origine et ca a marché direct.
Merci pour ton aide
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Problème setTexturingMode   Today at 3:38 am

Back to top Go down
 
Problème setTexturingMode
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
 :: Forum Francais :: Questions (fr)-
Jump to: